Blog

Windows 8.1 and Internet Explorer 11

October 17th, 2013 by admin

October 17, 2013 marked the release of Windows 8.1 and Internet Explorer 11.

Historically, Atomic8Ball has supported the current version of Internet Explorer, Firefox, and Chrome, as well as the 2 most recent versions of Internet Explorer. This means that when IE10 was the most current version of Internet Explorer, we also supported IE 8 and 9.

What does "supported" mean?

Part of our quality control process is to look at each update in the browsers that we support to confirm the visual appearance of the update. Slight inconsistencies between the browsers may cause styling to appear correct on two of them, but break in some fashion on the third one.

So what's changing?

Starting with IE9, each version of Internet Explorer has become increasingly more standards compliant, which is a good thing. During the life cycle of IE10, we never saw a single instance where the visual appearance between IE9 and IE10 was such that the display appeared correct in one, but broken in the other. If the update looked right in IE10 it looked right in IE9, but might look wrong in IE8. Testing has shown this to continue to be the case with IE11.

We are adjusting our quality control process to just look at the current version of Internet Explorer, the same that we do with other modern browsers.

What impact should be expected?

You shouldn't experience any differences, unless you or your clients are running Windows XP and are therefore unable to use modern versions of Internet Explorer. Please see the below list if IE version numbers and the minimum version of Windows required to run it.

IE version num - Minimum Windows version required
IE 7 (10/2006) - Windows XP SP2 (08/2004)
IE 8 (03/2009) - Windows XP SP2 (08/2004)
IE 9 (03/2011) - Windows Vista SP2 (04/2009)
IE10 (10/2012) - Windows 7 (10/2009)
IE11 (10/2013) - Win 8.1 now, coming soon to Windows 7 (10/2009)

There's really no expectation that anybody is using IE7, as any non-pirated version of Windows XP can run IE8. However, Windows XP is at the end of it's lifecycle, with legacy support ending April 8, 2014.  For anybody presently using Windows XP and IE8, we recommend upgrading to a modern OS with and using a modern browser.

What if I have a special case?

If you have a special case, then please discuss it with us.

Posted in: announcement,